Skip to content

machine_controller

check production list discrepancies

1
2
3
4
5
6
7
import machine_controller as mac
import cadwork

btl_enum = 5 # VERSION: "BTL V10.6"
# The enumeration is done according to the machine export listing in the export menu.
file_path   = 'C:\\Downloads\\api_btl.btl'
mac.export_btl(btl_enum, file_path)
1
2
3
4
5
6
import machine_controller as mac
import cadwork

hundegger_enum = 3 # Hundegger K2
# The enumeration is done according to the machine export listing in the export menu.
mac.export_hundegger(hundegger_enum)